Exchange Impaired

Incident Report for Nativo

Resolved

We have verified that the fix has resolved the issue
Posted Oct 08, 2025 - 16:04 PDT

Monitoring

We have implemented a fix and are monitoring the status.
Posted Oct 08, 2025 - 15:55 PDT

Identified

We have identified an underlying issue with the load balancing layer and are working to resolve.
Posted Oct 08, 2025 - 15:40 PDT

Investigating

We are investigating an issue with the performance of the Exchange systems
Posted Oct 08, 2025 - 15:24 PDT
This incident affected: Nativo Ad Platform (Ad Serving System, SSP/Exchange).